Implementing Mikrotik Mpls Vpls Setup For Iii Offices.
This lab demonstrates how to connect multiple branch offices to the HQ on Mikrotik routerOS, using MPLS alongside VPLS. One of the requirements that service providers teach is to furnish transparent connectivity betwixt offices.
MPLS forwarding allows service providers to speed upwards bundle forwarding on their networks. The purpose of Virtual Private LAN Service (VPLS) removes the involve for the encapsulation of ethernet frame forwarding inwards IP, thereby farther increasing the efficiency of ethernet frame forwarding. This LAB requires that in that place should endure no hops betwixt all branches.
MPLS forwarding allows service providers to speed upwards bundle forwarding on their networks. The purpose of Virtual Private LAN Service (VPLS) removes the involve for the encapsulation of ethernet frame forwarding inwards IP, thereby farther increasing the efficiency of ethernet frame forwarding. This LAB requires that in that place should endure no hops betwixt all branches.
Network Design
All networks depicted inwards network diagram volition endure configured as well as advertised on the heart as well as somebody as well as all PE routers using OSPF to furnish amount convergence as well as reachability amid provider border routers.
Loopback interfaces volition endure created on the heart as well as somebody as well as all PE routers for LDP connection.
On PE routers, no IP addresses volition endure assigned to interfaces connecting to the customers.
Implementation
On the heart as well as somebody router: IP address assignment
First of all, practise a loopback interface as well as assign an IP to it:
/interface duad add together name=lobridge
/ip address add together address=4.4.4.2/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=1.1.1.1/24 interface=ether1 comment=”connection-to-NY”
/ip address add together address=2.2.2.1/24 interface=ether2 comment=”connection-to-CA”
/ip address add together address=3.3.3.1/24 interface=ether3 comment=”connection-to-TX”
On the heart as well as somebody router: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=1.1.1.0/24
/routing ospf network add together area=backbone network=2.2.2.0/24
/routing ospf network add together area=backbone network=3.3.3.0/24
/routing ospf network add together area=backbone network=4.4.4.2/32
On NY PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.1/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=1.1.1.2/24 interface=ether1 comment=”connection-to-Core”
On the NY PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=1.1.1.0/24
/routing ospf network add together area=backbone network=4.4.4.1/32
On CA PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.3/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=2.2.2.2/24 interface=ether1 comment=”connection-to-Core”
On CA PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=2.2.2.0/24
/routing ospf network add together area=backbone network=4.4.4.3/32
On TX PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.4/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=3.3.3.2/24 interface=ether1 comment=”connection-to-Core”
On TX PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=3.3.3.0/24
/routing ospf network add together area=backbone network=4.4.4.4/32
At this point, nosotros should accept reachability to all loopback IPs from all PE routers. Next, nosotros volition enable MPLS label distribution protocol (LDP) on the heart as well as somebody as well as all PE routers as well as add together participating interfaces. LDP carry address volition endure ready to the loopback address configured on each router. The argue for this is because nosotros practise non desire interface condition to impact LDP vecino relationship. Also, because nosotros practise non desire alter inwards addressing should non impact mpls setup.
MPLS LDP configuration on the core
/mpls interface
ready [ notice default=yes ] interface=ether1
add together interface=ether2
add together interface=ether3
/mpls ldp ready enabled=yes lsr-id=4.4.4.2 transport-address=4.4.4.2
/mpls ldp interface
add together interface=ether1
add together interface=ether2
add together interface=ether3
/mpls ldp neighbor
add together transport=4.4.4.1
add together transport=4.4.4.3
add together transport=4.4.4.4
MPLS LDP configuration on the NY PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.1 transport-address=4.4.4.1
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
MPLS LDP configuration on the CA PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.3 transport-address=4.4.4.3
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
MPLS LDP configuration on the TX PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
At this point, nosotros accept a fully configured MPLS cloud. Next, nosotros implement VPLS mapping to connect branches together. On each PE router, in that place volition endure 2 VPLS mapping to achieve 2 other locations.
VPLS configuration on NY PE
interface vpls
add together comment=”NYtoCA” disabled=no l2mtu=1500 name=”NYtoCA” remote-peer=4.4.4.3 vpls-id=10
add together comment=”NYtoTX” disabled=no l2mtu=1500 name=”NYtoTX” remote-peer=4.4.4.4 vpls-id=10
/interface duad add together name=NY-Bridge
/interface duad port add together bridge=NY-Bridge interface=ether2
/interface duad port add together bridge=NY-Bridge interface=NYtoCA
/interface duad port add together bridge=NY-Bridge interface=NYtoTX
VPLS configuration on CA PE
interface vpls
add together comment=”NYtoCA” disabled=no l2mtu=1500 name=”CAtoNY” remote-peer=4.4.4.1 vpls-id=10
add together comment=”NYtoTX” disabled=no l2mtu=1500 name=”CAtoTX” remote-peer=4.4.4.4 vpls-id=10
/interface duad add together name=CA-Bridge
/interface duad port add together bridge=CA-Bridge interface=ether2
/interface duad port add together bridge=CA-Bridge interface=CAtoNY
/interface duad port add together bridge=CA-Bridge interface=CAtoTX
VPLS configuration on TX PE
interface vpls
add together comment=”TXtoNY” disabled=no l2mtu=1500 name=”TXtoNY” remote-peer=4.4.4.1 vpls-id=10
add together comment=”TXtoCA” disabled=no l2mtu=1500 name=”TXtoCA” remote-peer=4.4.4.3 vpls-id=10
/interface duad add together name=TX-Bridge
/interface duad port add together bridge=TX-Bridge interface=ether2
/interface duad port add together bridge=TX-Bridge interface=TXtoNY
/interface duad port add together bridge=TX-Bridge interface=TXtoTXtoCA
All networks depicted inwards network diagram volition endure configured as well as advertised on the heart as well as somebody as well as all PE routers using OSPF to furnish amount convergence as well as reachability amid provider border routers.
Loopback interfaces volition endure created on the heart as well as somebody as well as all PE routers for LDP connection.
On PE routers, no IP addresses volition endure assigned to interfaces connecting to the customers.
Implementation
On the heart as well as somebody router: IP address assignment
First of all, practise a loopback interface as well as assign an IP to it:
/interface duad add together name=lobridge
/ip address add together address=4.4.4.2/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=1.1.1.1/24 interface=ether1 comment=”connection-to-NY”
/ip address add together address=2.2.2.1/24 interface=ether2 comment=”connection-to-CA”
/ip address add together address=3.3.3.1/24 interface=ether3 comment=”connection-to-TX”
On the heart as well as somebody router: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=1.1.1.0/24
/routing ospf network add together area=backbone network=2.2.2.0/24
/routing ospf network add together area=backbone network=3.3.3.0/24
/routing ospf network add together area=backbone network=4.4.4.2/32
On NY PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.1/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=1.1.1.2/24 interface=ether1 comment=”connection-to-Core”
On the NY PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=1.1.1.0/24
/routing ospf network add together area=backbone network=4.4.4.1/32
On CA PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.3/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=2.2.2.2/24 interface=ether1 comment=”connection-to-Core”
On CA PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=2.2.2.0/24
/routing ospf network add together area=backbone network=4.4.4.3/32
On TX PE: IP address assignment
/interface duad add together name=lobridge
/ip address add together address=4.4.4.4/32 interface=lobridge
Then, assign IP addresses to interfaces connecting to PE routers:
/ip address add together address=3.3.3.2/24 interface=ether1 comment=”connection-to-Core”
On TX PE: OSPF advertisement
/routing ospf illustration ready redistribute-connected=as-type-1
/routing ospf network add together area=backbone network=3.3.3.0/24
/routing ospf network add together area=backbone network=4.4.4.4/32
At this point, nosotros should accept reachability to all loopback IPs from all PE routers. Next, nosotros volition enable MPLS label distribution protocol (LDP) on the heart as well as somebody as well as all PE routers as well as add together participating interfaces. LDP carry address volition endure ready to the loopback address configured on each router. The argue for this is because nosotros practise non desire interface condition to impact LDP vecino relationship. Also, because nosotros practise non desire alter inwards addressing should non impact mpls setup.
MPLS LDP configuration on the core
/mpls interface
ready [ notice default=yes ] interface=ether1
add together interface=ether2
add together interface=ether3
/mpls ldp ready enabled=yes lsr-id=4.4.4.2 transport-address=4.4.4.2
/mpls ldp interface
add together interface=ether1
add together interface=ether2
add together interface=ether3
/mpls ldp neighbor
add together transport=4.4.4.1
add together transport=4.4.4.3
add together transport=4.4.4.4
MPLS LDP configuration on the NY PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.1 transport-address=4.4.4.1
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
MPLS LDP configuration on the CA PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.3 transport-address=4.4.4.3
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
MPLS LDP configuration on the TX PE
/mpls interface
ready [ notice default=yes ] interface=ether1
/mpls ldp ready enabled=yes lsr-id=4.4.4.4 transport-address=4.4.4.4
/mpls ldp interface
add together interface=ether1
/mpls ldp neighbor
add together transport=4.4.4.2
At this point, nosotros accept a fully configured MPLS cloud. Next, nosotros implement VPLS mapping to connect branches together. On each PE router, in that place volition endure 2 VPLS mapping to achieve 2 other locations.
VPLS configuration on NY PE
interface vpls
add together comment=”NYtoCA” disabled=no l2mtu=1500 name=”NYtoCA” remote-peer=4.4.4.3 vpls-id=10
add together comment=”NYtoTX” disabled=no l2mtu=1500 name=”NYtoTX” remote-peer=4.4.4.4 vpls-id=10
/interface duad add together name=NY-Bridge
/interface duad port add together bridge=NY-Bridge interface=ether2
/interface duad port add together bridge=NY-Bridge interface=NYtoCA
/interface duad port add together bridge=NY-Bridge interface=NYtoTX
VPLS configuration on CA PE
interface vpls
add together comment=”NYtoCA” disabled=no l2mtu=1500 name=”CAtoNY” remote-peer=4.4.4.1 vpls-id=10
add together comment=”NYtoTX” disabled=no l2mtu=1500 name=”CAtoTX” remote-peer=4.4.4.4 vpls-id=10
/interface duad add together name=CA-Bridge
/interface duad port add together bridge=CA-Bridge interface=ether2
/interface duad port add together bridge=CA-Bridge interface=CAtoNY
/interface duad port add together bridge=CA-Bridge interface=CAtoTX
VPLS configuration on TX PE
interface vpls
add together comment=”TXtoNY” disabled=no l2mtu=1500 name=”TXtoNY” remote-peer=4.4.4.1 vpls-id=10
add together comment=”TXtoCA” disabled=no l2mtu=1500 name=”TXtoCA” remote-peer=4.4.4.3 vpls-id=10
/interface duad add together name=TX-Bridge
/interface duad port add together bridge=TX-Bridge interface=ether2
/interface duad port add together bridge=TX-Bridge interface=TXtoNY
/interface duad port add together bridge=TX-Bridge interface=TXtoTXtoCA
0 Response to "Implementing Mikrotik Mpls Vpls Setup For Iii Offices."
Post a Comment